Google anunciou que vai perder o suporte para algumas das suas versões do Android mais velhos quando se oferece a próxima atualização para suas bibliotecas serviços do Google Play.

A versão atual suporta o nível API Android 9, que vai todo o caminho de volta para o Android 2.3 Gingerbread. Mas quando a versão 10.2.0 do Google Play bibliotecas clientes serviços é lançado, o Google irá aumentar o nível mínimo suportado API a 14, fazendo Android 4.0.1 Ice Cream Sandwich a versão mais antiga suportada do sistema operacional. Essa mudança vai inevitavelmente ver o fim do suporte para Android 3.0 Honeycomb também.

 

Google explicou :

A plataforma Gingerbread tem quase seis anos de idade. Muitos desenvolvedores do Android já descontinuaram o suporte para Gingerbread em seus aplicativos. Isso os ajuda a construir melhores aplicações que fazem uso dos recursos mais recentes da plataforma Android.Para nós, a situação é a mesma. Ao fazer essa mudança, vamos ser capazes de fornecer um conjunto mais robusto de ferramentas para desenvolvedores do Android com maior velocidade.

Os últimos dados oficiais do Google mostra que 1,3% dos dispositivos Android estão agora executando Gingerbread, enquanto que menos de 0,1% estão em favo de mel, e Google diz que acredita “que muitos destes dispositivos antigos não estão sendo ativamente utilizado”.

Enquanto mais velhos dispositivos Gingerbread e Honeycomb ainda terá acesso aos serviços do Google Play usando a versão 10.0.0 bibliotecas, aplicativos construídos e mantidos com as mais recentes 10.2.0 bibliotecas não funcionará nessas versões anteriores do OS. Google diz que os desenvolvedores “pode construir múltiplas APKs que suportam diferentes níveis mínimos de API, com diferentes versões do Google Play serviços” – mas é improvável que muitos desenvolvedores estarão dispostos a colocar no esforço necessário para fazê-lo por uma pequena proporção tão grande de usuários .

O próprio Google recomenda que os desenvolvedores agora alvo nível API 14 e Android 4.0.1 como a versão mínima suportada, e que eles deveriam “descontinuar o suporte para níveis de API que deixará de receber atualizações do Google Play serviços”.

Google ainda não anunciou uma data exata para essas mudanças, mas diz que a versão 10.2.0 das bibliotecas do cliente serviços do Google Play será lançado “no início de 2017”.

Fonte:Desenvolvedores Android